Need help?  •  Forgot your password?
This web site will be decommissioned in June 2019. Visit our new site here.

Support

Frequently Asked Questions


This is a collection of frequently asked questions and their answers about our courseware packages.

General

Software Questions

Installing the software

Boole

Submit and the Grade Grinder

Submit and the Grade Grinder for Students

Submit and the Grade Grinder for Instructors

Macintosh

Windows

Linux


General

Q. How do I get your software?

A. Our software is only available to purchasers of our courseware packages.

Q. OK so how do I get your courseware packages?

A. All of our packages may be bought directly from our publisher, or from good bookstores (click or brick).

Q. Now that I have your software, how do I register it?

A. You only need to register your software if you plan to use the Grade Grinder service. You register by making a submission to the Grade Grinder. The instructions for doing this are on pages 8--10 of Language, Proof and Logic, or pages 5--7 of Tarski's World.

You will be unable to log on to the web site until you have registered your software in this way. There is no way to register at the web site.

Q. What version is my program?

A.  To find the version of a program:

When a program is started, its "about window" (sometimes called a "splash screen") is displayed briefly.

The version information is located in the top right hand corner (bottom right corner for old versions).

In Windows or Linux, while a program is running, going to the Help menu and selecting the About... item, should open an "about window".

On a Macintosh, while a program is running, going to the application menu and selecting the About... item, should open an "about window".


Software Questions

Q.  I think that I have found a bug in the software. How can I report it?

A.  You can use our bug report page to report any bugs that you think that you have found. We ask for a lot of information. Please be as specific as you can, since the more information we have the easier it is for us to find and fix the problem.

Q.  Which platforms will your software run on?

A.  We support our software on the following operating systems:
  • Windows Vista/7/8/10
  • MacOS X 10.7-10.11
  • 64-bit Fedora Core and Ubuntu Linuxes

We do not provide support for platforms provided by virtualization software (for example VirtualBox, BootCamp, Parallels, VMWare, Virtual PC).

There are some known compatibility issues with Windows.

We support only LTS releases of Ubuntu.

Older versions of our software have, and current software may still, run on:
  • Windows NT/98/ME/2000/XP
  • MacOS 8.5-8.6, MacOS 9.x, 10.1-6 and the Classic environment on MacOSX
  • 32-bit Fedora Core and Ubuntu Linuxes
but we no longer support these operating systems.

back to top


Installing the Software

Q.  Can I install the software on my laptop?

A.  Certainly. Feel free to install the software on any computer you intend to work on.

Q.  Can I run the software directly from the CD/floppy disk?

A.  Certainly. Just double-click on the applications or exercise files as you normally would.

Q.  I am an instructor. Can I install your software on the computers in our lab?

A.  Yes, provided that you are teaching a class in which students are required to purchase individual copies of the package. The software should be removed from public computers at the end of the term in which the class is taught.

Q.  The disk that came with my package appears to be blank. What should I do?

A.  You can register on the website and then login and download the software. You'll need the registration id printed on the face of the CD.

You might like to try the disk in a different machine to see if the disk is really blank. While errors can creep in during production our experience suggests that this problem usually occurs because of an OS related problem such as outdated drivers. If the disk is visible on other machines, then you should probably update your drivers anyway.

Q.  On a mac, the upgrade or download isn't installing. What should I do?

A.  Note that on a Mac the download and install takes a few steps.
  1. Download the LPL-13_10.pkg file (the name may change depending on revision). This may be done automatically.
  2. Double click on the file and follow instructions for installing.

Q.  My computer doesn't have a CD drive. What should I do?

A.  You can register on the website and then login and download the software. You'll need the registration id printed on the face of the CD.

Alternatively:

  • Use the CD in a machine that does have a drive and run the submit program directly from the CD to make a submission (you can use the test submission file in the beginning of the textbook).
  • Use a classmate's copy of Submit to make a submission using the registration id from your disk.
  • No classmates? Send us a message and we will try to help. Include your registration id, email you will be using to submit, and full name.

back to top


Boole

Q.  I tried to print from Boole, but the printing option seems to be disabled. What am I doing wrong?

A.  You are using a very old version of Boole. Early versions were not able to print but the current version can. If you have registered your software you can download the latest versions of the software by logging in as a student.

back to top


Submit and the Grade Grinder

Submit and the Grade Grinder for Students

Q.  What is the Registration ID?

A.  The Registration ID is an identifying number which serves as your registration key for the Grade Grinder grading service. Without it you will not be able to use the Grade Grinder or log in to the web site.

Q.  Where can I find my Registration ID?

A.  The registration ID is printed directly on the CD. It is a sequence of letters and numbers, something like L21-1234567. In very old releases it is printed on a label attached to the sleeve containing the CD. If you bought the package online, it was emailed to you.

Q.  I bought a used copy of the package. Why doesn't my Registration ID work?

A.  Registration IDs are non-transferable. Likely the Registration ID is registered to whoever originally owned the book. Please return your copy of the package to the bookstore that sold it, and buy a new courseware package. If you have questions about our policy in this regard, see our Email Change Policy .

Q.  I bought a new copy of the package. Why doesn't my Registration ID work?

A.  Most likely, you misspelled your name or email address when you first used Submit. You can change your registration information within 30 days of registration by logging in to correct the mistake. You will have to know what the misspelled name/email was, however. If you are still having trouble, contact us and we will investigate.

If you are sure that this is not the problem then you may have bought a defective copy of the package. We apologize; this happens occasionally. Please return it to the book seller.

Q.  Submit is not able to connect to the Grade Grinder. Ever. Is your server down?

A.  Possibly, but if this is persistent the problem is more likely to be that you are behind a firewall. If so you need to specify a proxy server. You can do this by selecting the Settings... item from the File menu in Submit. If you are unsure of the information to enter here, you should try duplicating the information in your web browser's proxy settings, or check with your local technical support people.

You can also modify the preferences so that Submit will wait longer for a response from the Grade Grinder, and/or use a specified server. Each of these may have an impact on your success in connecting.

Q.  Submit says that it cannot deliver mail to my email address. What should I do?

A.  When you make a submission, Submit sends your grade report by email to your registered email address. Sometimes, the mail is returned to us (it "bounces"). This can happen for a number of reasons. Common ones are:
  • You spelled the email address incorrectly,
  • Your email account is over quota,
  • The computer to which your email is delivered is unvailable (down, or not on the network)
  • A spam filter on the computer to which your email is delivered is blocking our address.
though there are many others.

When we receive a mail bounce, we mark your account to indicate this, and you will be unable to Submit again until the problem is fixed. In any case, you must tell us that the problem is fixed, by visiting our web site and updating your address (even if it remains the same.) It takes about fifteen minutes for the system to be fully updated after doing this.

What you must do to fix the problem varies depending on the nature of the problem. Obviously, if the email address is spelled incorrectly, you should correct it. If your account is over quota, deleting mail will be the solution. You probably can't do anything about the network or mail host being down.

If you are the victim of an over-eager spam filter, there are a couple of things that you can try. The first is to change your preferred server using Submit's preferences. If only one server is being blocked by the filter, then use the other. Having changed your Submit settings, you will then need to visit the web site and reset your address to clear the flag. Don't forget to wait for about fifteen minutes for the system to reset.

Q. Submit accepts my submission, but I don't get a grade report. What should I do?

A.  Please read this page for an explanation of the many things that can go wrong with mail delivery, and some things to try.

Q.  Will my professor know if I make mistakes when I submit grade reports to myself?

A.  If, when you send in your files using Submit, you check "Just to Me" instead of "Instructor Too", your instructor will never know. You can submit the same files over and over, until you get the exercises right.

Submit and the Grade Grinder for Instructors

Q.  I'm a new instructor, and I want to use he Grade Grinder for my next class. Do I need to contact someone or prepare ahead of time?

A.  You should register your course with us. The link to that page can be found from in the Instructor Resources . You'll also find some other information about using the Grade Grinder that may be helpful. Other then that, we recommend that you make arrangements for the software to be installed on computers that your students will have access to -- in a campus computer lab, for example. We also recommend that you familiarize yourself with the software, so that you can help your students with any questions that they may have. Many of our instructors like to devote one class session to talking about or demonstrating the use of the software.

Q.  I have several teaching assistants. How can I register all our email addresses so that students can submit their work to all of us?

A.  You may want to set up a mailing list for yourself and your teaching assistants. See Registration and Teaching Assistants for more information.

Q.  How can I tell if a student sends me a forged grade report?

A.  You can download the original grade report for a submission from our web site. Just navigate to the submission and click the grade report link. You can also see, and download, the student's original files here.

Q.  I received a grade report indicating a timestamp collision. How can I find out the identity of the other student?

A.  You can retrieve the collision report for the submission from the web site. Just navigate to the relevant submission and click the collision link.

Q.  I accidently deleted my grade reports. Is there any way to recover them?

A.  You can download the original grade report for a submission from our web site. Just navigate to the submission and click the grade report link. You can also see, and download, the student's original files here.

Macintosh

Q. Programs aren't opening or aren't opening properly.

A.  The programs are sensitive to the correct version of java. Lion (10.7) or later users should see http://support.apple.com/kb/dl1572 for a fix. Snow Leopard 10.6 users should see http://support.apple.com/kb/DL1573.

Q. When I use "Save as" the program crashes

A. When you open the "save as" dialog, you see a small window showing a spot for the name of the file, with a pulldown menu beneath it for selecting the place to save. Using the pulldown causes the crash.

Fortunately, there is a workaround. Instead of using this small window, click on the button to the right of the file name. This will open a larger file dialog which will allow you to navigate the file system without using the pulldown menu.

Depending on the mode of this dialog, you will see different things: a panel of icons, a list of files, etc; The mode is determined by a row of buttons to the right of the two arrows arrows in the row beneath the file name. All of the modes will enable you to navigate inside folders, but if you need to navigate up to a parent folder, you will need to be in column mode, which you select using the button that looks like three columns.

Our applications remember where you last saved a file, and MacOS remembers the settings for the dialog, so only the first save is so problematic.

Q. When I submit, gradegrinder sends back a message saying "This file was ungradable either because it is not a X file, or is damaged"?

A.  Assuming that the files are correctly named and open in the respective programs, the most likely reason is that you are trying to send an 'alias' file instead of the actual file. Submit does not handle alias files correctly so instead you have to find and point to the actual file.

Windows

Q. What is the "Windows Key"?

A.  Most PC keyboards have a "Windows key" (also known as the "Windows-logo key"), and it's usually located in the bottom-right of the keyboard, between the Control/Ctrl and Alt keys.

The Windows key operates analogouly to a Shift, Control/Ctrl, or Alt key. That is, to press "Windows-r" (written also as "Windows+r&quot), which is referred to as a "keyboard shortcut", you hold down the Windows key, then press the "r" key.

There are keyboard shortcuts for a number of functions.

Q. How do I open "Windows Help"?

A.  Windows comes bundled with some online help. This is available by selecting the Help item in the Start menu. (You might also try the keyboard shortcut, Windows+F1.)

Windows Help has a search option where you can type in a keyword or phrase to get a list of related topics.

Q. How do I create a "Windows shortcut"?

A. To learn how to create a shortcut, open Windows Help, and search for the phrase (include the quotation marks):

"create a shortcut"

Q. What is the Windows "Run Command" or "Run Dialog"?

A. Windows has a Run Command dialog into which you can type the name of a program, folder, document, or Internet resource, and Windows will open it for you.

To open this Run dialog, try using the keyboard shortcut, Windows+r. (Sometimes, there is a Run item in the Start menu.)

If you need more help, open Windows Help, and search for the phrase (include the quotation marks):

"run command"

Q. How do I send you DirectX information (dxdiag) about my Windows system?

A.  Open the Run dialog, then enter:

dxdiag

The DirectX Diagnostics window has a button to "Save All Information". Use that to create a file, then email it (as an attachment or its contents) to us. Thank you.

Q. How do I send you my Windows "System Information"?

A.  To learn how to open the "System Information" window, use Windows Help, to search for the phrase (include the quotation marks):

"System Information"

Depending on your edition of Windows, one of the results should be something like:

  • What is System Information
  • Using System Information
  • Display system data
One of them should describe or give you the option to open "System Information". Once opened, choose to save the information to a file, then send us that file as an attachment.

Q. How do I "print screen"?

A.  To learn how to do a "print screen" or "screen capture", open Windows Help, and search for the phrase (include the quotation marks):

"print screen"

NOTE: On most notebook computers, to press the "Print Screen" key (which might be abbreviated as "prt sc"), you'll have to hold down a "function" key (typically labeled "fn" and located in the bottom left corner of your keyboard) then press the "Print Screen" (generally located in the upper right corner of your keyboard).

To save the "screen capture" to a file, open Microsoft Paint by opening the Run dialog, and entering:

mspaint
Then, paste and save.

Q. One or more of the programs does not work under Windows, How do I get it to work?

A.  It could be a problem with the program but sometimes Windows guesses wrong on compatibility so try first the following:
  • Right Click Submit.exe (or the program causing problems)
  • Select Properties
  • Select Compatibility mode
  • Check "Run this program in compatibility mode Windows XP (sp 3)". (or some other older version of Windows)

Q. Is your software compatible with Windows Vista?

A.  Our programs will drop your system's color scheme into Vista Basic. By itself, this is purely cosmetic.

There are issues with Tarski's World 6 in some system configurations.

For more information about the Vista Basic color scheme, open Windows Help, and search for the phrase (include the quotation marks):

"Vista Basic"

Q.  On Windows Vista, the world pane in Tarski's World 6 covers up the tool buttons or has other display problems.

A.  We have seen this problem on systems using integrated graphics by Intel, specifically the 945GM and 965 Express Chipsets.

You can check what graphics your system uses by running dxdiag, selecting the Display tab, then looking in the Device area.

Something that has worked is to set the "Depth Buffer Bit Depth" to "16 Bit Depth Buffer":

  1. Right-click on the desktop, look for and select the "Graphics Properties..." popup menu item (or something similar, but NOT "Graphics Options").

    This should open the "Intel Graphics Media Accelerator Driver" control panel.

    If not, look in the list of Control Panels for "Intel(R) GMA Driver" (or something similar; "GMA" stands for "Graphics Media Accelarator").

  2. Click on the "3D Settings" button to open a "OpenGL Settings" window, which has a table with two columns: "Attribute" and "Value".

  3. Go to the "Depth Buffer Bit Depth" attribute, then click in its value column for a pulldown menu. Set it to "16 Bit Depth Buffer".

  4. Click the "Apply" button.

If this does not work for you, please send us the dxdiag information!

We are sorry for this inconvenience.

Q. On Windows, Submit freezes navigating to my files.

A. This problem is caused by Windows shortcut files which Submit cannot handle.

First, be sure that you are running the most recent version of Submit. If you recently bought an online package you are up to date, if you bought a physical book then you are likely to need to update. If you bought a physical book have not made a submission, then you will need to register here before you can log in.

If you are using the most recent version of the software and are still having a problem, then there are two workarounds until we are able to fix this problem:

  • The first is to use the “Choose File To Submit” menu item (on the File menu), which allows the selection of one file at a time to be added to the submission list.
  • Submit freezes when it encounters a certain kind of shortcut (alias) file. It happens that some versions or configurations of Windows place such a file on the desktop, which is the first place that Submit looks. One more permanent way to fix the problem then, is to determine which file it is, and ensure that it is not on the path to the LPL folder (or ultimately, to wherever you keep your work).

    For this work around, the trick is to move all of the files on the Desktop to a folder, perhaps called “temporary” on the desktop. Submit should then be able to navigate to the desktop. Then you can restore the files one at a time to determine which file(s) need to stay in temporary to avoid the bug. Or not, since Submit remembers where work was last submitted from, the navigation problem only really occurs when you haven’t navigated to the work folder the first time. All of the files can be restored to the desktop once the need to navigate through that folder has been removed.

While recent versions of the software have improved behavior with this problem, we do not yet have a fix for all instances of this problem. We are sorry for this inconvenience.


Linux

Q.  Why does the Tarski splash screen hang when starting?

A.  From the command line, try running the program:

glxinfo

If you see the message:

Extension "GLX" missing on display ":0.0"

You need to either change your X configuration to load the glx extension or install a video driver which supports glx. Unfortunately both of these changes can be complicated and are beyond the help that we can give in this FAQ. A good place to start to look for help would be a web search including your flavor of linux, your video hardware and the term glx.

Q.  How can I install the software using the rpm or deb Linux package management system?

A.  We provide Linux installers for the Red Hat and Ubuntu flavors of linux. Both of these installers are really just shell scripts which automate the installation of a number of rpm (in the case of Red Hat) or deb (in the case of Ubuntu) packages. Once installed they should be visible through the package management software that your OS provides along with all the other packages installed on your system. Furthermore, you can use those tools to subsequently remove the software from your system if you so desire.

back to top