Need help?  •  Forgot your password?
This web site will be decommissioned in June 2019. Visit our new site here.

Support

Documentation


Boole

Boole is an application that makes it easy to construct truth tables. We begin with instructions on how to start and stop Boole, and explain the basic layout of the screen.

5.1 Getting started



Figure 5.1: Main Boole window.

The Boole application is contained inside the folder called BooleFolder. When Boole is running, you will see (from top to bottom) the menu bar, the “table tool bar”, the “sentence tool bar”, ’a narrow pink “assessment pane,” and finally a large, mostly blank area for constructing truth tables, called the “table pane.” Here are the basic facts to remember about each of these.

5.1.1 The menus

Boole has the following menus:

5.1.2 The tool bars

At the very top of the window is the table tool bar which is very like those in the corresponding places in Fitch and Tarski’s World. There are buttons here for changing the size and format of the sentences to be displayed in the truth tables, as well as three buttons for checking and making edits to the table.

Immediately below this toolbar is the sentence toolbar containing logical symbols and predicates. It is just like the sentence tool bar in Tarski’s World and Fitch. Clicking on a button enter the corresponding symbol or predicate, if the insertion point is located in one of the sentence fields at the top of your table.

5.1.3 The assessment pane

The assessment pane is similar to the goal pane in Fitch. This is where you look to see whether your truth table is correctly constructed. It also contains a button that allows you to assess the target sentence or sentences in your table. When you click the Assessment button, you are presented with a list of possible assessments. For example, if you are asked to determine whether a sentence is a tautology, you can specify whether or not it is. If you are asked to determine whether a sentence is a tautological consequence of other sentences, you can specify this here as well.

5.1.4 The table pane

The large, mostly white area is where you construct truth tables. A thin horizontal line divides the headings of the columns from the truth value columns. A thick vertical line divides the reference columns from the body of the table. When the insertion point is in the heading area, you can enter target sentences on the right or reference sentences on the left. New sentence columns are added using the commands Add Column After or Add Column Before from the Table menu. Once sentences are entered, truth values can be entered in the appropriate places under those sentences.

5.1.5 Adjusting the table pane

The table pane is divided into two parts: the reference columns on the left and the target columns on the right. These are separated by a vertical divider. Often when you open or construct a table, you will not be able to see all of the columns on one or the other side. You can adjust the overall size of your window in the usual way, and you can also change the position of the divider by grabbing it and dragging to the left or right.

5.2 Writing and editing tables

There are three steps in creating a truth table: specifying the target sentence (or sentences), building the reference columns, and filling in the truth values. Once a table is complete, it can be used to assess the logical properties of the target sentences.

5.2.1 Entering target sentences

To enter a target sentence, the insertion point must be blinking in the upper right section of the table. If it is not, click in this area to place the insertion point where you want it. Then enter the desired sentence using the tool bar or keyboard. To type the logical symbols from the keyboard, refer to this table of keyboard equivalents.


Keyboard equivalents for typing symbols.

            
SymbolKey    SymbolKey
¬~    #
&     
$%
@/
_\


Notice that as you enter the sentence, the sentence number above the sentence changes color. If the sentence is ill-formed, the number is red; when it is well-formed, it turns green.

If you are constructing a joint truth table for two or more sentences, you will need to choose Add Column After or AddColumn Before from the Table menu to add a new target sentence to your table.

Another way to enter sentences is by copying them from Tarski’s World or Fitch and pasting them into the appropriate place in Boole.

5.2.2 Creating reference columns

There are two ways to create reference columns: you can do it by hand or you can have Boole do the work for you. You should always do the work yourself unless the exercise or your instructor gives you permission to let Boole build the reference columns for you.

To enter a reference sentence, click at the top of the first column to the left of the thick dividing line. Then enter the desired atomic sentence. (Boole will allow you to enter any formula in a reference column. The number above the sentence will be red if the sentence is ill formed and blue if it is not atomic.) To add additional reference sentences, choose Add ColumnAfter or Add Column Before from the Table menu, and enter the sentence.

If you want Boole to build the reference columns for you, click on the button Build Ref Cols on the tool bar. This will generate the necessary reference columns for the target sentences currently appearing on the right. If Boole generates the reference columns, they will be numbered =1=, =2=, …; if you build them, they will be numbered (1), (2), ….

5.2.3 Filling in truth values

To fill in truth values in your table, click in the desired column and type T or F. (You can also type “1” for T and either “0” or “2” for F, if you find this more convenient.) After the letter is entered, the insertion point will move down one row in the same column. If you are working in a column on the right side of the table, Boole will highlight the values elsewhere in the table that the current value depends on. In other words, Boole implements the “two finger” method described in the textbook.

Boole will also fill in truth values in the reference columns of a table automatically, should you so desire. Only do this if the exercise or your instructor says that you can. (The Grade Grinder will complain if you do this without permission.) To fill them in automatically, select the Fill Reference Columns item from the Table menu.

In its default mode, Boole will fill in values column by column. That is, when you type a T or F, the insertion point will move down one row so that you can fill in the next value in the column. If you prefer filling in your table row by row, choose By Row in the Edit menu. In Row mode, Boole will move the insertion point to the next column after you type a truth value.

5.3 Specifying your assessment

Typically you will be asked to use truth tables to determine whether a sentence is a tautology, whether two sentences are tautologically equivalent, or whether a sentence is a tautological consequence of others. Thus after you have constructed your truth table, you will need to specify the relevant assessment of the sentence or sentences in your table. To do this, click on the Assessment button in Boole’s assessment pane. This will open a window allowing you to specify your assessment.

5.4 Verifying your table

There is a single command for verifying your table. This is available both from the Table menu and on the tool bar. Verifying the table involves three steps.

  1. First, each of the rows is checked. If all of the references columns are present and the values filled in under the target sentence are correct, a checkmark will appear to the left of the row on the target side of the table.
  2. Next the correctness and completeness of your entire table is checked. Boole checks whether the table has exactly the required rows that it needs. If a row is missing, or if there are extra rows, then this check will fail, otherwise a checkmark will appear adjacent to the sentence in the target sentence area.
  3. Finally Boole checks to see whether your assessment is correct. Before it can do this, you must specify an assessment, as described above. The checkmark for this will appear in the assessment area.

5.5 Saving or printing your table

To save your table, choose Save or Save As from the File menu. If you are submitting a table to the Grade Grinder, you should name it Table n.m, where n.m is the number of the exercise.

To print a table, choose Print from the File menu. When you do this, you will be given the standard print dialog box. Once you have chosen any printer options you want to use, click on the Print button in the dialog box.

5.6 Preferences

Some aspects of the behavior of Boole can be controlled using the preferences dialog. This can be accessed by choosing the Preferences... command from the application menu (Edit Menu on Windows).



Figure 5.2: Boole Preferences Dialog

The preferences allow you to control the style of text for sentences that you prefer. You can specify a font size, and whether Boole should use italic or bold font for displaying formulae.

There is a global preference which controls whether all of the applications check for updates when they are launched. If this box is checked, the application will determine if an update is available, and ask if you want to download and install it.