Need help?  •  Forgot your password?
This web site will be decommissioned in June 2019. Visit our new site here.

Support

Documentation


Tarski

Tarski’s World lets you represent simple, three-dimensional worlds inhabited by geometric blocks of various kinds and sizes, and test first-order sentences to see whether they are true or false in those worlds. We begin with instructions on how to start and stop Tarski’s World, and explain the basic layout of the screen.



Figure 3.1:Main window of Tarski’s World.

3.1 Getting started

The Tarski’s World application is contained inside the folder called Tarski’s World Folder. Also in this folder is a folder called TW Exercise Files, in which you will find the Tarski’s World exercise files referred to in the book.

When Tarski’s World is running you will see a large window divided into two sections. The left world panel contains a checkerboard on which blocks are placed, called a world, and a tool bar for manipulating the content of this world, which we call the “world tool bar”. Immediately above the world is a tab which contains the name of the world. Initially this is Untitled World.

The sentence panel is the white panel to the right of the window. At first it contains only the numeral “1” inside. This is where sentences are entered and evaluated to see whether they are true or false in the world represented in the world window. Feel free to type something in the sentence window, say, “I’d rather be in Philadelphia.” Immediately above the sentences is a tab which contains the name of the collection of sentences. Initially this is Untitled Sentences.

The sentence toolbar appears above the sentence panel. We generally use these tools to enter sentences of first-order logic. Feel free to play around by clicking on the buttons in the sentence toolbar.

3.1.1 Opening saved files

Both worlds and sentence lists can be saved as files on your disk. Indeed, many prepackaged world and sentence files come with Tarski’s World. To open a saved file, you use the Open command on the File menu.

To open a file, pull down the Filemenu and choose Open …. A file dialog will appear which allows you to navigate to the file that you wish to open. You will have to navigate to the right folder to find the prepackaged files, which are in TW Exercise Files . Find this folder, select it, and then click Open , or simply double-click on the name. Feel free to open one of the files you see, say, Ackermann’s World, but if you make any changes to the world, don’t save them.

When you open a file, a new tab will be created above the new sentence or world panel. 1 This tab will contain the name of the file that you opened. To return to viewing any other world or sentence file, just click on its tab, and it will reappear.

3.1.2 Starting new files

If you want to start a new world or sentence file, choose New from the File menu. You may then specify whether you want a new world or new sentence file from the menu which appears. The New World and New Sentences commands create a new empty world or sentence panel as appropriate. These are created as new tabs within the collection of worlds or sentences.

The command New Random World on the New menu creates a new world, and populates it with randomly chosen blocks.

The New Window item on the New menu creates a new window identical to the initial main window.

You may have noticed that there is another New command on the File menu. depending on which panel is active, this reads New Sentences or New World, and is equivalent to the corresponding item on the New submenu. This item also has a shortcut.

3.1.3 Saving a file

If you want to save a file, use the Save submenu from the File menu. There are items here which allow you to save the current world, Save World or Save World As..., the current sentences, or all worlds and sentences in all tabs.

If the file has never been saved before, a dialog box will appear giving you the option of naming the file you are about to create. If you were to hit the return key, or click the Save button, the file would be saved with the default name. You should type in some other name before hitting the return key or clicking Save. You should also make sure you are saving the file where you want it. Check the directory name at the top of the save dialog box. If you’re not in the folder where you want to save the file, navigate to the right one by clicking on this name.

You may have noticed that there is another save command on the File menu. depending on which panel is active, this reads Save Sentences or Save World, and is equivalent to the corresponding item on the Save menu. This item also has a shortcut.

Once a file has been saved, the name of the file appears in the corresponding tab. If you are working on a named file, the Save and Save As  commands behave differently. The first will save a new version of the file under the same name, and the old version will be gone. The second gives you a chance to create a new file, with a new name, and keeps the old file, with its name. For this reason, Save As  is the safer of the two options.

You can also access the save commands by right-clicking or control-clicking (Macintosh) on the corresponding tab.

All files created by Tarski’s World can be read by either the Macintosh or Windows version of the application.

3.1.4 Closing Tabs

When you are done with a world or sentence file, you can close it using the Close commands on the File menu. As usual, there is a command which closes the active tab whether it is a world or sentence, and a submenu which allows you to close the tab of your choice. The close commands can also be accessed from the tab’s menu or by clicking on the close icon on the tab itself.

3.1.5 Reverting a File

If you want to reload a tab from its corresponding file, you can do so using the Revert submenu on the File menu. You will be asked first whether you want to save the changes that you have made to the file (to a different file), and then the content of the current tab will be replaced from the file. This command an also be accessed from the tab’s menu.

3.1.6 Printing

To print your sentences or world, choose the appropriate Print  command from the File menu, or from the tab’s popup menu. If your computer is not connected to a printer, this probably won’t work.

3.1.7 Quitting (Exiting) Tarski’s World

Eventually you will want to leave Tarski’s World. To do this, choose Quit from the application menu ( Exit from the File menu on Windows). If you’ve made any unsaved changes to the files, Tarski’s World will give you a chance to save them.

3.2 The World Panel

In this section we explain how to create, edit and save worlds. Worlds can be edited using a variety of different commands. Each of these can be undone using the Undo command from the File menu, and redone using the Redo command, on the same menu.

3.2.1 Adding blocks

To put a block on the grid, simply click the New button on the tool bar. This is the leftmost button on the toolbar, and looks like an arrow pointing at the world, with blocks above it. Try this out. The size and shape of block that is created can be controlled by setting a preference (see section  3.6 ). A small cube is created by default.

3.2.2 Selecting blocks

A block can be selected by clicking on it. The block will change color to indicate its selection. To deselect a block, click elsewhere in the world window.

To select more than one block, hold down the command key (control key on Windows) while clicking on the blocks. If many blocks are selected, and you want to deselect one of them, click on it while holding down the shift key.

3.2.3 Moving blocks

To move a block, position the cursor over the block and drag it to the desired position. (That is, move the mouse’s arrow over the block and then, with the button depressed, move the mouse until the block is where you want it.) If multiple blocks are selected, they will all move. There is one exception to this. Large blocks are so big that they overlap onto the adjoining squares. Consequently, it is impossible to move blocks so that a large block adjoins a square that is occupied.

If you move a block (or blocks) too close to the edge it will fall off.

3.2.4 Sizing and shaping blocks

To change a block’s shape, select it and click on one of the shape buttons on the toolbar. These display a tetrahedron, cube and dodecahedron and change the shape appropriately. If multiple blocks are selected all will changed to the new shape.

Similarly, to change a block’s size, select it and click on one of the size buttons on the toolbar. These display circles of small, medium and large sizes. If multiple blocks are selected all will changed to the new size. There is one exception to this. Large blocks are so big that they overlap onto the adjoining squares. Consequently, it is impossible to make a block large if it adjoins any square which has a block on it.

3.2.5 Naming blocks

When a block is selected, the name checkboxes on the toolbar are activated. To add a name to the selected block, click on the appropriate name button, which looks like a cube with a name on it. If the box is already selected, the name will be removed from the block.

In first-order logic, one object can have several names, but two objects cannot share the same name. Hence Tarski’s World lets you give a block more than one name, but once a name is used, that name cannot be assigned to another block. So if one block is named a and you want a different block to be named a, you must remove the name from the first block before adding it to the second.

3.2.6 Deleting blocks

To delete a block, drag the block off the edge of the grid and drop it. Alternatively, select the appropriate block or blocks and hit the Delete key.

3.2.7 Cutting, copying, and pasting blocks

If you want to copy some blocks from one file to another, use the cut, copy, and paste functions.

If you select blocks and then choose Cut or Copy from the Edit menu , the blocks are stored on the computer’s clipboard. The difference between the two commands is that Cut deletes the blocks from their present position, while Copy leaves them in place. You can’t see the contents of the clipboard, but the blocks will be there until you cut or copy something else to the clipboard.

Once some blocks are on the clipboard, they can be pasted into a different (or the same) world. Just select the relevant tab and choose Paste from the Edit menu. A copy of the blocks on the clipboard will be inserted.

You can paste several copies if you want to, even into the same world. Tarski’s World will attempt to paste the blocks in the same configuration as they were cut, but will need to move them if there are already blocks in any of those positions. Because two blocks cannot have the same name, pasted blocks will have their names removed.

3.2.8 Hiding labels

Whenever you name a block, Tarski’s World labels the block with its name. Of course, in the real world we only wear name tags at unpleasant social occasions. Like us, blocks in Tarski’s World can have names without wearing labels. To hide the labels, simply choose Hide Labels from the World menu. To redisplay the labels, choose Show Labels from the World menu.

This command toggles the display of labels in all open worlds.

3.2.9 2-D view

Labels aren’t the only things that can hide. Sometimes a small block can be obscured from view by another block in front of it. To get a bird’s eye view of the world, choose 2-D View from the World menu. To get back to the usual perspective, choose 3-D View from the World menu. These commands can also be accessed from the tool bar using the button which looks like a small version of the checkerboard.

Blocks can be moved, selected, and changed from the 2-D view in exactly the same way as the 3-D view. You can even change to the 2-D view in the middle of playing the game (see section  3.5 ); sometimes you will have to in order to pick an appropriate block, or to see what Tarski’s World is referring to.

3.2.10 Rotating Worlds

To rotate a world by 90 degrees in either direction, choose Rotate World Clockwise or Rotate World Counterclockwise from the World menu. Such a rotation counts as a change to the world and will be saved when you save the world.

You can also rotate the world from the tool bar using the arrow buttons.

3.3 The Sentence Panel

There are two ways to enter formulas into the sentence window, from the sentence toolbar or from the keyboard. Most people find it easier to use the toolbar than the keyboard.

All sentence edits can be undone and redone using the Undo and Redo commands from the File menu.

3.3.1 Writing formulas

Tarski’s World makes writing first-order formulas quite painless. As you may have noticed while playing with the sentence toolbar, when you enter a predicate, like Tet or BackOf, the insertion point locates itself in the appropriate position for entering “arguments”—variables ( u, v, w, x, y, z ) or individual constants ( a, b, c, d, e, f ).

What this means is that a sentence like BackOf(a,b) can be entered into the sentence list with three mouse clicks in the toolbar: first on the BackOf button, then on the a button, then on the b button. To enter the same thing from the keyboard would require 11 keystrokes.

In order to allow you to write more readable formulas, Tarski’s World treats brackets (“[ ]”) and braces (“ {   } ”) as alternatives to parentheses when grouping formulae. Thus, for example, you could write [ LeftOf ( a,b ) Large ( a )] and Tarski’s World will read this sentence as ( LeftOf ( a,b ) Large ( a )). But you have to type brackets and braces from the keyboard, and you must use parentheses to indicate the arguments in atomic sentences.

3.3.2 Commenting your sentences

You can add comments to your sentences in a way that will be ignored by the program when it is checking to see if they are well formed or true. You do this by prefacing each line of text you want ignored by a semicolon (;). This will cause Tarski’s World to ignore anything that follows on the same line. Tarski’s World displays all of the characters in the comment in green to remind of their (in)significance.

3.3.3 Creating a list of sentences

To create a whole list of sentences, you first enter one sentence, and then choose Add Sentence After from the Sentence menu. You are given a new, numbered line, and can then enter a new sentence. If you hit the Return (or Enter) key, this will not start a new sentence, but will simply break your existing sentence into two lines. Use Add Sentence After !

Instead of choosing Add Sentence After from the Sentence menu, you can do this from the toolbar by clicking the Add After button or you can do it directly from the keyboard in two ways. You can type Shift-Return (that is, hit the Return (or Enter) key while holding the shift key down) or use the keyboard equivalent shown in the menu.

To insert a new sentence in your list before the current sentence, choose Add Sentence Before from the Sentence menu, or using the Add Before button on the toolbar.

3.3.4 Moving from sentence to sentence

You will often need to move from sentence to sentence within a list of sentences. You can move the insertion point with the up and down arrow keys ( , ) on the keyboard or by clicking on the sentence of interest with the mouse. The left and right arrow keys ( , ) on the keyboard also move the insertion point, but only within a single sentence.

If you hold down the Option key, the up arrow takes you to the first sentence of the list, the down arrow takes you the last sentence of the list, and the left and right arrows take you to the beginning and the end of the current word. Holding down the command key while using the left and right arrow keys will move to the beginning or end of the current sentence.

3.3.5 Deleting sentences

To delete a whole sentence and renumber the sentences that remain, choose Delete Sentence from the Sentence menu. First make sure the insertion point is somewhere in the sentence you want to delete.

Note that you cannot highlight parts of two different sentences and then delete them. If you want to delete a sentence boundary, you must use the command Delete Sentence from the Sentence menu.

3.3.6 Typing symbols from the keyboard

Sentences can be entered into the sentence window by typing them on the physical keyboard. When typing predicates in the blocks language, you must be sure to spell them correctly and to capitalize the first letter (since otherwise they will be interpreted as names, not predicates). You also have to insert your own punctuation: parentheses after the predicate, and commas to separate multiple “arguments” (as in Between(a,x,z)). To get the logical symbols use the keyboard equivalents shown below.


Keyboard equivalents for typing symbols.

            
SymbolKey    SymbolKey
¬~    #
&     
$%
@/
_\


Either the sentence window or the Keyboard window must be “active” before typing on the physical keyboard will have any effect. If you type and nothing shows up, that’s because the world panel is currently the active panel. To activate the other panel, just click in it somewhere.

You can change the size of the font used to display sentences using the Text size submenu on the Sentence menu.

3.3.7 Cutting, copying, and pasting

If you want to change the order of the sentences in a list, or copy a sentence from one file to another, use the cut, copy, and paste functions.

If you highlight a string of symbols and then choose Cut or Copy from the Edit menu , the string of symbols is stored on the computer’s clipboard. The difference between the two commands is that Cut deletes the highlighted symbols from their present position, while Copy leaves them in place. You can’t see the contents of the clipboard, but the symbols will be there until you cut or copy something else to the clipboard.

Once something is on the clipboard, it can be pasted anywhere you want it. Just put the insertion point at the desired place and choose Paste from the Edit menu. A copy of the string of symbols on the clipboard will be inserted. You can paste several copies at several different points, if you want to.

You can copy sentences out of Tarski’s World and paste them into Fitch or Boole, and vice versa.

3.4 Verifying syntax and truth

As you will learn, only some strings of symbols are grammatically correct, or well formed, as we say in logic. These expressions are usually called well-formed formulas, or wffs. And only some of these are appropriate for making genuine claims about the world. These are called sentences. Sentences are wffs with no free variables. You will learn about these concepts in the text.

To see if what you have written in the sentence window is a sentence, and if so, whether it is true in the world currently displayed, click on the Verify button in the toolbar. This is the leftmost of the group of three colored buttons on the toolbar. Alternatively, you can type Command-Return (Control-Enter on Windows). If you want to check a whole list of sentences, choose Verify All Sentences from the Sentence menu. Alternatively, use the Verify All button on the tool bar, which is in the center of the group..

When you verify a sentence, the results are displayed in the margin to the left of the sentence number: “ T ” or “ F ” indicates that the sentence is true or false in the world, “ * ” indicates that the formula is not well-formed or not a sentence, while “+” indicates that the formula is a sentence of first-order logic, but not evaluable in the current world. When you enter something that is not well-formed, Tarski’s World will display the portion of the expression after the error in red. If you are unsure why a sentence is not evaluable, verifying the sentence again will result in a dialog explaining the reason.

The evaluations are removed when the sentence or world is changed.

3.5 Playing the game

When you stake out a claim about a world with a complex sentence, you are committed not only to the truth of that sentence, but also to claims about its component sentences. For example, if you are committed to the truth of a conjunction A B (read “A and B”) then you are also committed both to the truth of A and to the truth of B. Similarly, if you are committed to the truth of the negation A (read “not A”), then you are committed to the falsity of  A.

This simple observation allows us to play a game that reduces complex commitments to more basic commitments. The latter claims are generally easier to evaluate. The rules of the game are part of what you will learn in the body of this book. Here, we will explain the kinds of moves you will make in playing the game.

To play the game, you need a guess about the truth value of the current sentence in the current world. This guess is your initial commitment. The game is of most value when this commitment is wrong, even though you won’t be able to win in this case.

Clicking on the Game button, the rightmost of the group of three colored buttons on the toolbar, will start the game. Tarski’s World will begin by asking you to indicate your initial commitment. At this point, how the game proceeds depends on both the form of the sentence and your current commitment. A summary of the rules can be found in Table 9.1 in Chapter 9 of the textbook.

3.5.1 Picking blocks and sentences

As you see from the game rules, at certain points you will be asked to pick one sentence from a list of sentences. You do this by clicking on the desired sentence and then clicking OK.

At other points in the game, you will be asked to pick a block satisfying some formula. You do this by moving the cursor over the desired block and selecting it. Then click OK. If necessary, Tarski’s World assigns a name to the chosen block, for example n1, and labels it.

3.5.2 Backing up and giving up

Tarski’s World never makes a mistake in playing the game. It will win if it is possible for it to win, that is, if your initial commitment was wrong. However, you may make a mistake, and so lose a game you could have won. All it takes is some bad choices along the way. Tarski’s World will take advantage of you. It will not tell you that you made a bad move until it has won, when it will inform you that you could have won. What this means is that there are two ways for you to lose: if you were wrong in your initial assessment, or if you make a faulty choice in the play of the game. To put this more positively, if you win a game against the computer, then you can be quite sure that your initial assessment of the sentence, as well as all subsequent choices, were correct.

To make up for the edge the computer has, Tarski’s World allows you to retract any choices you have made, no matter how far into the game you’ve gone. So if you think your initial assessment was correct but that you’ve made a bad choice along the way, you can always retract some moves by clicking on the Back button. If your initial assessment really was correct, you should, by using this feature, eventually be able to win. If you can’t, your initial commitment was wrong.

The Back button undoes the last step of the game, while the Reconsider button undoes all of the moves since the last time that you made a choice.

If, halfway through the play of the game, you realize that your assessment was wrong and understand why, you can stop the game by clicking the End Game button. This ends the game, but does not shut down Tarski’s World.

3.5.3 Controlling the interaction in the game

There are three checkboxes which can be used to control the detail with which the game is presented. Some moves can be carried out completely automatically rather than require you to click a confirmation button. We recommend leaving these in the checked (most verbose) position until you gain some experience with the game. The function of these checkboxes are described below

3.5.4 When to play the game

In general, you won’t want to play the game with every sentence. The game is most illuminating when you have incorrectly assessed a sentence’s truth value, but are not sure why your assessment is wrong. When this happens, you should always play the game without changing your commitment. Tarski’s World will win, but in the course of winning, it will usually make clear to you exactly why your assessment was wrong. That’s the real value of the game.

You might wonder what happens when you play the game with a correct assessment. In this case, if you play your cards right, you are guaranteed to win. But Tarski’s World does not simply give up. At those points in the game when it needs to make choices, it will make them more or less randomly, hoping that you will blunder somewhere along the line. If you do, it will seize the opportunity and win the game. But, as we have noted, you can always renege by backing up.

3.6 Preferences

Some aspects of the behavior of Tarski’s World can be controlled using the preferences dialog. This can be accessed by choosing the Preferences... command from the application menu ( Edit Menu on Windows).



Figure 3.2: Tarski’s World Preferences Dialog

The first row of preferences are checkboxes which allow you to switch on some options for opening and creating new worlds.

You can opt to create a random world instead of an empty one when a new world is created by selecting the open with random world checkbox. You can view an animation as the world is opened or created by selecting the open with flythrough checkbox, and you can opt to always open worlds in 2-D by selecting the final checkbox.

You can control the speed of animations, or switch all animations off using the Animation panel. The speed of animations is controlled by a slider. When the slider is set to the Fast end of the scale, the animations will have fewer frames, resulting in a more jerky animation which takes less time. The Smooth end of the scale will result in smoother, but longer, animations. You might like to play with this setting to get the effect that is just right for your computer. If nothing seems right, then you can switch all animation off.

You can choose a different effect for how new blocks are created, varying from dropping from the sky, materializing or growing in place. We think that the effects are pretty nifty. You might like to try them out.

The final world preference determines the size and shape of the block that is created when the New Block button is pressed. You have the option of being presented with a dialog box, always creating the same kind of block, or allowing Tarski’s World to choose a size and shape for you.

The final option specific to Tarski’s World concerns the display of text in the sentence pane. You may opt to specify a default font size for the sentence panel.

There is a global preference which controls whether all of the applications check for updates when they are launched. If this box is checked, the application will determine if an update is available, and ask if you want to download and install it.